Leaf Blower World

This site is dedicated to the maintenance and use of leaf blowers.

Diagnosis of ECHO PB260L Leaf blower

Written By: Leaf Blower Guy - Mar• 07•14

I have since unjammed the ring and it now runs. Visit my channel for more repair videos; www.youtube.com
Video Rating: 5 / 5

Originally posted 2011-05-27 04:51:25. Republished by Blog Post Promoter

Incoming search terms:

  • yhs-att_001
  • echo pb 260l problems
  • ECHO BLOWER PB4600 SPEC
  • PISTON STUCK ON LEAF BLOWER
  • my echo blower leaking gas
  • how to replace rings on echo blower
  • echo pb260l problems carburetor cleaning
  • echo PB260L problems
  • Echo pb260l Carburetor Problems
  • echo pb260 blower not getting enough gas at full throttle

You can follow any responses to this entry through the RSS 2.0 feed. You can leave a response, or trackback from your own site.

25 Comments

  1. zuuluu1 says:

    The rings will work it self into the piston ovr time. Some old piston rings r completly stuck in the piston when I work on them and that doesnt matter as long as u the compresion is good. I could c the piston to good because of all the oil and carbon but it looked prety messed up at the top. Also check the carb settings to make sure they havent been messed with. Some times the vibration can change it. Could check the engine coil to.

  2. Daveoflyers says:

    I have the same model. Last week it began blubbering past half throttle. I just put a new carb on it,cleaned out the intake and exhaust 100% , replaced the fuel filter, checked and cleaned the coil and stator but same result. Any help out there?

  3. julioyperla says:

    @donyboy73 ok thx u very much. i will try the compression.

  4. donyboy73 says:

    @julioyperla the compression might be too low, i would have to physically see it to help u more

  5. julioyperla says:

    @donyboy73 hi there! i just put a new carb kit anf still does not want to start what should i do next? i got spark i checked allready!

  6. julioyperla says:

    @donyboy73 ok man i’m a get the kit and let’s see what happens and thank you very much for ur help. i appresiate it.

  7. donyboy73 says:

    @julioyperla that’s not a guarantee

  8. julioyperla says:

    @donyboy73 so even if is leaking gas trought the choke the kit would take care of that ?

  9. donyboy73 says:

    @julioyperla it’s cheaper getting a kit then a new carb. it’s rare that i have to replace a carb

  10. julioyperla says:

    @donyboy73 it is a walbro, and i try to make it run and is too much gas caming out of the carb , it even get the filter all soak from all the gas coming trought the choke , so do u think a kit would do it or do i just need a new carb,? what do u think? i just don’t want to get the kit and end up been just a waste of money cause i needed the carburetor./

  11. julioyperla says:

    @donyboy73 it is a walbro, and i try to make it run and is too much gas caming out of the carb , it even get the filter all soak from all the gas coming trought the choke , so do u think a kit would do it or do i just need a new carb,? what do u think? i just don’t want to get the kit and end up been just a waste of money cause i needed the carburetor./

  12. donyboy73 says:

    @julioyperla CAN U TELL ME IF IT’S A ZAMA CARB OR WALBRO? IF IT’S A WALBRO A k10-wat KIT IS WHAT U NEED

  13. julioyperla says:

    hello there ! nice video it helps alot , thx. but i got a ? i need the carb kit ,what kind of kit do i need to buy for this blower?

  14. BiziM5 says:

    @donyboy73 Sorry for my delay. During that clean-out, I broke 1-ring. So, I purchased a new piston kit and carb (the manual–says to inspect and replace annually). It started and ran at low throttle, but not full power. My brother (Electrician) heard it and said it’s missing–probably poor ignition. I just purchased a new ignition coil and will install it in a day or so. Your video helped, as now I can tear-down and rebuild quickly. I will keep you posted. Thanks.

  15. donyboy73 says:

    @BiziM5 i would have to see it, on this one i unseized the rings and cleaned the carbon out and it runs now

  16. BiziM5 says:

    Thanks for this. I have the same model (I think about 4-yrs). I found the carbon build-up thru the exhaust port and clean it out, replaced plug and fuel filter. Mine starts and runs fine on low power, but at full throttle, the blower speed and power falls off. I don’t know if its a lack of compression or an impeller problem. Any ideas?

  17. th19940305 says:

    Oh, i bought a pb-413h off a guy for $20 and it came with all but the tubes, it had less than an hour on it and then died on him. I don’t know if Echo will give me the warranty if i don’t have paperwork for it but i just put on a new carb and it works. I don’t know why the other one didn’t work?

  18. donyboy73 says:

    @th19940305 1 year old, used as a homeowner. it’s the lower end that echo makes for a backpack blower

  19. th19940305 says:

    Was it used comercially it looks like it had around 2-300 hours (from all the carbon)

  20. donyboy73 says:

    @th19940305 1 year old

  21. th19940305 says:

    How old was it?

  22. th19940305 says:

    What happened to it? Where did you get it in the first place?

  23. donyboy73 says:

    @th19940305 don’t have it anymore

  24. th19940305 says:

    Nice video i learned something new. Can you make a video of it running?

  25. ringbolt9 says:

    interesting to watch you solve these mysteries

  26. tracy guidry says:

    i have pb260l gas blower i have toke the carb down twice clean but having the same problem it will crank and idle great but boggs down when you give it trottle. i purchase a carb kit but i am looking for instructions on butting kit in.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Powered by Yahoo! Answers